Symptoms
When running XpressPOS or the Application Integration
"report" from the 2020 Reports on Design form, you get the 2020 Warning
below:
"You do not have access privileges to this report."
Cause
This can be caused by any of the following (in "most
likely" order) :
1. You have not installed the 2020 Application
Integration Module.
2. Your 2020 Security Key does not have the add-on
license for the XML data (Application Integration module).
3. If you are using 2020 Version 6.4 and the 2020
registry was deleted (2020 Support has users do this to correct other 2020 problems).
4. The XML license code that was forwarded to your
company was not entered into the "Revision" form in the 2020 Maintenance tool. This code reprograms the Security
device.
5. Your 2020 Security Key XML license has run out. This
could happen if you received a new key to replace the old one and there may only be a 15 day license on it.
Resolution
For the above items:
1. Download and install the latest 2020 Application
Integration Module for your particular 2020 version.
http://www.2020.net
2. Contact your 2020 Sales Representative or 2020 Direct
Sales and have your Security Key number available (KDCU number).
3. See Resolution #1.
4. Find the email with the revision code (EX:
632097E25497A1439947E58622AF6237205638003B3434DB).
Then run the 2020 Maintenance program from the Programs
Menu .
Under "Internal" you will find the Revision command.
Paste the code into the text box.
Q14704 - ERRMSG: You do not have access privileges to
this report
5. Email 2020 Support and with your Security Key number (KDCU
number).