Symptoms
When running XpressPOS you get an
error message:
Called From: Xpresspos.opentable
Unhandled Structured Exception.
Message: Table 'C:\....\xpresspos2006\....dbf" has been corrupted.
Cause
This could be caused by an improper shut down of the
XpressPOS program. This in turn could be due to power failure, pressing the off button, or being forced to Alt,
Ctrl, Del. and end the XpressPOS task.
This could corrupt any open working tables. The working
tables are probably empty at the time and are very susceptible to corruption. This error never seems to happen to tables
with permanent data.
Resolution
Reinstall XpressPOS. NOT RECOMMENDED!
Workaround
Assuming that XpressPOS is installed in the default
installation folder, C:\Program Files\Saberis, then use Explorer (right click on the Start button in XP or Vista
and select Explore) and delete the files as instructed below.
When you run XpressPOS, the program will automatically
recreate the deleted files.
-
If the error occurred while running the
XpressPOS Kitchens (2020) Module, find the
C:\Program Files\Saberis\Xpresspos2006\kitchens\data\ folder.
Now highlight and delete the following ten (10) files :
kitchendetail.dbf
kitchendetail.cdx
kitchendetail.fpt
kitchenheader.dbf
kitchenheader.fpt
kitchengroup.dbf
kitchengroup.fpt
kitchengroupoptions.dbf
kitchengroupoptions.cdx
kitchengroupoptions.fpt
NOTE: Do NOT delete any files with the word “catalog” in
the name.
-
If
the error occurred while running the XpressPOS
Andersen (iQ) Module, find the C:\Program
Files\Saberis\Xpresspos2006\Andersen\data\ folder.
Now highlight and delete all five (5) files:
andersendetail.cdx
andersendetail.dbf
andersendetail.fpt
andersenheader.dbf
andersenheader.fpt
-
If
the error occurred while running
any other XpressPOS
Module, find the
C:\Program Files\Saberis\Xpresspos2006\data\ folder.
Now highlight and delete all seven (7) files:
xmldetail.dbf
xmldetail.cdx
xmldetail.fpt
xmlheader.dbf
xmlheader.fpt
xmlsection.dbf
xmlsection.fpt